Degraded O365 job performance

Incident Report for m4

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 13:16 UTC

Monitoring

We experienced a temporary performance degradation that affected some Office 365 backup jobs over the weekend. The issue has already been resolved, and all backups are now running as expected. We will continue to monitor the system to ensure ongoing stability.
Posted Mar 23, 2026 - 06:08 UTC